45 lines
1.1 KiB
Nix
45 lines
1.1 KiB
Nix
{ inputs, config, lib, pkgs, outputs, ... }:
|
|
let
|
|
# Disko setup
|
|
fsType = "btrfs"; # one of ext4 or btrfs. Use btrfs if using impermanence
|
|
dev = "/dev/sda"; # depends on target hardware
|
|
encrypted = false; # currrently only applies to btrfs
|
|
btrfsMountDevice = if encrypted then "/dev/mapper/crypted" else "/dev/root_vg/root";
|
|
user = "admin";
|
|
in
|
|
{
|
|
imports =
|
|
[
|
|
# Create users for this host
|
|
../common/users/${user}
|
|
|
|
# Disk configuration
|
|
inputs.disko.nixosModules.disko
|
|
(import ../common/disks { device = dev; fsType = fsType; encrypted = encrypted; })
|
|
|
|
# Import core options
|
|
./hardware-configuration.nix
|
|
../common/core
|
|
|
|
# Import optional options
|
|
../common/optional/openssh.nix
|
|
|
|
];
|
|
|
|
boot.loader.grub.enable = true;
|
|
boot.loader.grub.device = "/dev/sda";
|
|
|
|
networking = {
|
|
hostName = "nebula";
|
|
networkmanager.enable = true;
|
|
enableIPv6 = false;
|
|
};
|
|
|
|
boot.supportedFilesystems = [ "zfs" ];
|
|
boot.zfs.forceImportRoot = false;
|
|
networking.hostId = "18aec5d7"
|
|
|
|
services.libinput.enable = true;
|
|
}
|
|
|