nixos/hosts/common/optional/gaming.nix

62 lines
990 B
Nix

{ pkgs, lib, ... }:
{
# Gaming
hardware.xone.enable = true;
environment.systemPackages = with pkgs; [
#Xbox controller
linuxKernel.packages.linux_zen.xone
# Steam
mangohud
gamemode
gamescope
# WINE
wine
winetricks
protontricks
vulkan-tools
# Lutris
lutris
# Extra dependencies
gnutls
openldap
libgpgerror
freetype
sqlite
libxml2
xml2
SDL2
];
nixpkgs.config.allowUnfreePredicate = pkg:
builtins.elem (lib.getName pkg) [
# Add additional package names here
"steam"
"steam-original"
"steam-run"
];
programs.steam = {
enable = true;
gamescopeSession.enable = true;
};
programs.gamemode.enable = true;
programs.gamescope.enable = true;
nixpkgs.config.packageOverrides = pkgs: {
steam = pkgs.steam.override {
extraPkgs = pkgs: with pkgs; [
pango
libthai
harfbuzz
gamemode
];
};
};
}