28 lines
573 B
Nix
28 lines
573 B
Nix
{...}:
|
|
{
|
|
fileSystems."/exports" = {
|
|
device = "/dev/vdb1";
|
|
fsType = "ext4";
|
|
};
|
|
|
|
services.nfs.server = {
|
|
enable = true;
|
|
# fixed rpc.statd port; for firewall
|
|
lockdPort = 4001;
|
|
mountdPort = 4002;
|
|
statdPort = 4000;
|
|
extraNfsdConfig = '''';
|
|
exports = ''
|
|
/exports *(rw,insecure,all_squash)
|
|
'';
|
|
};
|
|
# open nfs ports
|
|
networking.firewall = {
|
|
enable = true;
|
|
# for NFSv3; view with `rpcinfo -p`
|
|
allowedTCPPorts = [ 111 2049 4000 4001 4002 20048 ];
|
|
allowedUDPPorts = [ 111 2049 4000 4001 4002 20048 ];
|
|
};
|
|
}
|
|
|