51 lines
1.2 KiB
Nix
51 lines
1.2 KiB
Nix
{ inputs, ... }:
|
|
let
|
|
# Disko setup
|
|
fsType = "btrfs"; # one of ext4 or btrfs. Use btrfs if using impermanence
|
|
dev = "/dev/disk/by-id/ata-QEMU_HARDDISK_QM00005"; # depends on target hardware
|
|
encrypted = false; # currrently only applies to btrfs
|
|
impermanence = false; # currrently only applies to btrfs
|
|
user = "admin";
|
|
in
|
|
{
|
|
imports =
|
|
[
|
|
# Create users for this host
|
|
../common/users/${user}
|
|
|
|
# Root disk configuration
|
|
inputs.disko.nixosModules.disko
|
|
(import ../common/disks { device = dev; impermanence = impermanence; fsType = fsType; encrypted = encrypted; })
|
|
|
|
# Import core options
|
|
./hardware-configuration.nix
|
|
../common/core
|
|
|
|
# Import optional options
|
|
../common/optional/openssh.nix
|
|
../common/optional/lxd
|
|
|
|
];
|
|
|
|
boot = {
|
|
loader = {
|
|
systemd-boot.enable = true;
|
|
efi.canTouchEfiVariables = true;
|
|
timeout = 3;
|
|
};
|
|
};
|
|
|
|
networking = {
|
|
hostName = "nebula";
|
|
networkmanager.enable = true;
|
|
enableIPv6 = false;
|
|
};
|
|
|
|
boot.supportedFilesystems = [ "zfs" ];
|
|
boot.zfs.forceImportRoot = false;
|
|
networking.hostId = "18aec5d7";
|
|
|
|
services.libinput.enable = true;
|
|
}
|
|
|