30 lines
646 B
Nix
30 lines
646 B
Nix
# Example to create a bios compatible gpt partition
|
|
{
|
|
disko.devices = {
|
|
disk = {
|
|
vda = {
|
|
device = "/dev/vda";
|
|
type = "disk";
|
|
content = {
|
|
type = "gpt";
|
|
partitions = {
|
|
boot = {
|
|
size = "1M";
|
|
type = "EF02"; # for grub MBR
|
|
priority = 1; # Needs to be first partition
|
|
};
|
|
root = {
|
|
size = "100%";
|
|
content = {
|
|
type = "filesystem";
|
|
format = "ext4";
|
|
mountpoint = "/";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|