38 lines
699 B
Nix
38 lines
699 B
Nix
{ inputs, config, lib, pkgs, outputs,... }:
|
|
let
|
|
dev = "/dev/vda";
|
|
in
|
|
{
|
|
imports =
|
|
[
|
|
# Import core options
|
|
./hardware-configuration.nix
|
|
../common/core
|
|
|
|
# Import optional options
|
|
../common/optional/pipewire.nix
|
|
../common/optional/hyprland.nix
|
|
../common/optional/displayManager/sddm.nix
|
|
../common/optional/openssh.nix
|
|
|
|
# Create users for this host
|
|
../common/users/sam
|
|
|
|
];
|
|
|
|
boot.loader.grub.enable = true;
|
|
boot.loader.grub.device = "${dev}";
|
|
|
|
networking = {
|
|
hostName = "nixdev";
|
|
networkmanager.enable = true;
|
|
enableIPv6 = false;
|
|
};
|
|
|
|
services.libinput.enable = true;
|
|
|
|
system.stateVersion = "23.11";
|
|
|
|
}
|
|
|