70 lines
1.6 KiB
Nix
70 lines
1.6 KiB
Nix
{device ? throw "Must define a device, e.g. /dev/sda"}:
|
|
{
|
|
disko.devices = {
|
|
disk.main = {
|
|
inherit device;
|
|
type = "disk";
|
|
content = {
|
|
type = "gpt";
|
|
partitions = {
|
|
ESP = {
|
|
priority = 1;
|
|
name = "ESP";
|
|
start = "1M";
|
|
end = "512M";
|
|
type = "EF00";
|
|
content = {
|
|
type = "filesystem";
|
|
format = "vfat";
|
|
mountpoint = "/boot";
|
|
};
|
|
};
|
|
root = {
|
|
name = "root";
|
|
size = "100%";
|
|
content = {
|
|
type = "lvm_pv";
|
|
vg = "root_vg";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
lvm_vg = {
|
|
root_vg = {
|
|
type = "lvm_vg";
|
|
lvs = {
|
|
root = {
|
|
size = "100%FREE";
|
|
content = {
|
|
type = "btrfs";
|
|
extraArgs = ["-f"];
|
|
subvolumes = {
|
|
"/root" = {
|
|
mountpoint = "/";
|
|
};
|
|
|
|
"/persist" = {
|
|
mountOptions = [ "subvol=persist" ];
|
|
mountpoint = "/persist";
|
|
};
|
|
|
|
"/nix" = {
|
|
mountOptions = [ "subvol=nix" "noatime" ];
|
|
mountpoint = "/nix";
|
|
};
|
|
|
|
"/swap" = {
|
|
mountOptions = [ "noatime" ];
|
|
mountpoint = "/.swapvol";
|
|
swap.swapfile.size = "8192M";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|