29 lines
810 B
Nix
29 lines
810 B
Nix
{pkgs ? import <nixpkgs> {}}:
|
|
pkgs.mkShell
|
|
{
|
|
nativeBuildInputs = with pkgs; [
|
|
hugo
|
|
python311
|
|
poetry
|
|
];
|
|
|
|
NIX_LD_LIBRARY_PATH=/run/current-system/sw/share/nix-ld/lib;
|
|
NIX_LD=/run/current-system/sw/share/nix-ld/lib/ld.so;
|
|
shellHook = ''
|
|
${pkgs.cowsay}/bin/cowsay "Welcome to the baseddata.io development environment!" | ${pkgs.lolcat}/bin/lolcat
|
|
export LD_LIBRARY_PATH=$NIX_LD_LIBRARY_PATH
|
|
source .env
|
|
source .venv/bin/activate
|
|
get_session=$(tmux list-session | grep "baseddata")
|
|
|
|
if [ -z "$get_session" ];
|
|
then
|
|
tmux new-session -d -s baseddata
|
|
tmux split-window -h
|
|
tmux send-keys -t 0 "hugo server" C-m
|
|
tmux send-keys -t 1 "cd backend && uvicorn main:app --reload" C-m
|
|
echo "Baseddata running in dev tmux shell"
|
|
fi
|
|
'';
|
|
}
|